OpenAPI Code Generation Failing

Hello, I’m new to OpenAPI and a tool I’m using called Azure Autorest to generate an API client for Piwik PRO’s API. I’m running into errors from Autorest, and also when I go to Swagger & OpenAPI Online Validator | Swagger Parser, the OpenAPI spec doesn’t validate. I’m specifically downloading the OpenAPI spec at HTTP API — Piwik PRO Analytics Suite 18.13 documentation.

With Autorest, I’m seeing a lot of “schema violation” errors, and at the website, it says “Swagger schema validation failed.” and there’s a bunch of lines of output, too.

I am probably just going to write up a little API client in Python without these tools, but I thought I’d bring it up in case anyone’s interested, or if anyone has tips on generating an API client in a similar manner that has worked for them.

Have you tried to just import the specs into tool like Insomnia or Postman? Worked for me, with Insomnia

I have not. I’ll see if I can get around to trying that out.

Hi @addison,

It seems like an issue on our end, but our product team is already aware of it and plan to fix it shortly. I will let you know once it’s done!

Hi @Adam , good to know. Thanks!