SPA´s do not set UTM with custom URL

Hi ,

I have a hybrid-setting of normal pageviews and spa´s.
So for so good, the spa run with a custom URL so I can follow the steps. Example: (original URL) (custom URL)
My problem, when adding UTM to the URL the spa pageview does not set source/medium & campaign.

The custom URL is looking like this with UTM included:;utm_source=testing5&utm_medium=testing5&utm_campaign=testing5

(note there is no difference using & or “&amp” etc)

When entering the main page with the normal pageview tag all is fine.
Example: ?amp;utm_source=testing5&utm_medium=testing5&utm_campaign=testing5

Do I miss something in my setting? I am using the SPA template.

Hi @Martin,

It seems that URLs are not built properly when it comes to UTMs. You can use our article to properly include your campaigns: About the Piwik PRO URL builder | Piwik PRO help center

Its the &amp part that is not decoded back when pushing in the URL.