Virtual pageviews not working for internal search

Hi PiwikPRO team. I’ve been scouring the help centre for advice on why the number of pageviews is significantly lower than sessions. I’ve deduced from this article, that it’s because most visitors to my site are arriving by Google Ads and these URLs are tagged with keyword= (thus flagging them as internal search).

  1. I’ve tried to delete ‘keyword’ in the site search settings but I can’t do so (is this possible)? I’d rather the platform just didn’t consider this parameter an internal search function.

  2. I’ve tried to follow the virtual page view tag instruction, and whilst I see a pageview tag triggered in debug, it’s not working on the front end once deployed to live.

So I’m a bit stuck. The tag is published.

I also can’t understand why the site search event is showing up twice, I only triggered the page once.

In the configuration I also want the page URL to be dynamic, as I’m having to apply this for every landing from PPC and we use different pages for different themes.

Are you able to provide any guidance on what I might be doing wrong?


Hi. You can simply exclude the keyword param from the list. See what happened after I changed configuration:

And the result is:

As for tagging Google Ads campaign, I’d go with utm_term instead of keyword.

Note: default configuration adds the keyword param via global config, so you have to delete it in Administration -> Settings -> Global site & app settings.

Thank you @kuba - I’ve been trying to delete ‘keyword’ from the sites and apps section, and not the global site and app settings section! Perfect.

Sure. There’s a tooltip explaining it when you hover over the keyword in the specific site’s settings. Glad it helped. :slight_smile: