Google Data Studio connection stopped working

We were pulling data from piwik pro, but today the connection stopped working. I generated a new key, but I still see the same message.
Could you please help me with fixing it?

Community Connector Error

There was an error caused by the community connector. Please report the issue to the provider of this community connector if this issue persists.

Connector details

There was an error while authenticating with the Piwik PRO API. Check your credentials and try again.

Thank you,

Hello @Dmity,

We will check what is going on and get back to you.
In the meantime, are you using the latest version of the connector available here?

The latest version is always listed in our Help Center article: Looker Studio (Google Data Studio) integration | Piwik PRO help center

Unfortunately until our integration is released in Google’s Community Connector Gallery, we need to provide direct links, which means that when we update the connector, it needs to be manually updated with this link.

Hi @Piotrek , how do I know the version of the connector?
And why do I have 2 Piwik connectors, when I search for them in GDS?

Can this cause this problem?
Thank you,

@Dmity this is a known issue with Custom Connectors in Google Data Studio. Unfortunately when they are installed from outside of the official gallery, each time you update the connector, it’s added as a separate item on the list.

Do you also see a new item on the list here? If not, that’s the connector you used previously.

I know that this is inconvenient - sorry about that. Like I mentioned, we want to get our connector released in Google’s gallery, which will make updating it much easier.

You can test the new version by switching between connectors in a test report.
If the report shows that a source was removed, you can add the new one back by clicking on “Edit”, then by going to the “Setup” tab for widgets that are not working and selecting the “Data source”, like this:

Let me know if that’s clear. I just tested the latest version in my test report (as you can see above) and I’m not running into any issues.

Hi @Piotrek ,
I followed the link Looker Studio Overview from your first reply, entered the details to connect and got the following error:

So I’m getting the error with the latest connector.

Could you please check the logs with the connect attempts to understand where it’s failing? as I mentioned before I got the error with the old key, then I added a new key and creds, but I still getting the same error.

Thank you,

@Dmity we only see authentication errors in the logs, same as when providing wrong credentials. Could you check again if you used the right client ID and client secret? Is everything set up according to this article? Where can I find API credentials? | Piwik PRO help center

@Piotrek , I created 3rd key according to the specified article, copied the creds, followed the link Looker Studio Overview , entered the creds and the account name, which I took from Piwik PRO > Menu > Administration > Settings > Subscription , but I got the same error.

The probability that I’m doing it wrong is low, as I connected it back in April and it worked fine till today.

Please help to fix it. I’m available for a call, if it’s necessary.

Thank you,


I will reach out via PM to make sure that this is fixed.


I’ve got the same problem than Dmitry :frowning:

I’ve used the different links you sent.

Thanks for your support,

hello the piwik pro team,

i’m facing the same issue

Community Connector Error

There was an error caused by the community connector. Please report the issue to the provider of this community connector if this issue persists.

Connector details

There was an error while authenticating with the Piwik PRO API. Check your credentials and try again.

and using the latest version

if you have any idea about how to fix it, would be glad to hear :slight_smile:

thanks & have a lovely day

kind regards,


Same issue here:

Any update about this? :slight_smile:

Thank you


This is happening again. Do you have any explanation?

Thank you!

Best regards

Hi @Thomas_Anode_FR! We’re working on a new authorization flow, which will not only fix these kinds of issues, but also will allow us to get our integration released in Google’s Community Connector Gallery. However, the exact release date still remains unspecified. We’re aiming to release a few new versions of the connector in the upcoming weeks and months, since we’re currently working on fixing all minor and major issues reported for Looker Studio connector, to make it a more robust tool. I will give you an update when we set the date.

1 Like


I am having the same problem.

I am on version 1.2.0 and also tried with new api keys.


Hi @Jeff! I assume you meant 1.2.0, which is the latest, right? I’ll look into this with the devs and see if there’s anything we can do to help here.

The aforementioned process of preparing the connector to be published officially in the Google Gallery is still in progress, as the required new authorization flow in the product is being developed. We’re aiming to finally finish this process in Q2.

In the meantime, we’ll try to find some workaround to help you overcome those issues.

Hi @Emilia,

Yes I meant 1.2.0. Our reports work again.

Thank you.

Hi @Jeff! We found out that the issues are probably connected with the version update of Looker Studio itself. A lot of users on the Internet reported struggles with connecting to data sources and other problems, and for some of them they have been going on for weeks.
Unfortunately, we cannot do anything about that so let’s hope it doesn’t appear for you anymore.


We’ve been experiencing the same issue for a few days now, on the latest version 1.0.8.

For some of our websites, the connector is working correctly, but for others this error is occurring. Do you have a temporary or permanent solution to this connector issue?

Thank you in advance for any updates on the subject.

Kind regards,

Hey @LisaBlanchard! I strongly encourage you to update your connector (it will require a bit of manual work, as we’re still in the process of publishing the connector in the official Connector Gallery) to the latest version which is 1.2.0. You will see a huge improvement in the areas of filtering and stability. Here you can find the list of changes that were published since 1.0.8 that you’re currently using.

Here’s a detailed description on how to update the connector correctly.

If you have any questions, feel free to ask :blush: