Serverside Tracking - Session exceeded max configured length


we send our requests via own serverside app. The target is to count requests, like e.g. clicks on links vs. clicks on buttons. User recognition is not wanted. Each request should be assigned to a new user and to new session - only one request needs to be recorded in each session. IP adress ist constant. That’s the theory and actually it’s going well, but…

There are a lot of requests “Session exceeded max configured length”.
Every request have following parameter:

method: POST,
query_params: {
“cs”: “UTF-8”,
“dimension14”: “https://domain/…”,
“e_a”: …,
“e_c”: …,
“e_n”: …,
“h”: “09”,
“idsite”: “…”,
“lang”: “de-DE”,
“m”: “38”,
“rec”: “1”,
“s”: “18”,
“send_image”: “0”,
“ua”: “…”,
“uid”: “1714289898270”,
“url”: “…”,
“urlref”: “
uid = timestamp. So every neu request have neu unique uid.
cip not provided

Why is the user recognized again and the session continues to be written?

On the screenshot you can see, it will be searching for the Visitor ID = “6a278427f6aded94”, but all users on the screenshot have another Id´s. Uid is always different.

Hi @Bi_Bass,

Not sure if that’s supposed to be is or isn't :sweat_smile:.

My guess is that you have session hash enabled and since each request is sent by the same app/machine each event is added to the same session.

You can either disable the session hash in the Administration settings of your Piwik PRO site or use the sh HTTP Tracking API parameter to disable it on-demand:

Hi Antoni!
Thank you for the support on Sunday. :grinning:
Thanks for the tip. We’ll try it out.

By the way, would you mind providing 2 tracking requests from the same session? Either here or in a private message.

Even with session hash enabled I think that the change of user ID should result in a session split.

The IP ist almost always the same.

As you can see, Visitor ID, User ID and Cookie Id are always different.
For my understanding, in this case every new request belongs to the new visitor and new session should be opened. But we will adjust Administration settings und extra use sh=0 in the request.

As soon as a solution is found, I will also post it here for the community