URL parameter not excluded

I want to exclude a url parameter, so that the same page doesn’t generate several entries in the pages reports.
I added it in Administration → Websites & apps → the selected website → Settings → Exclude url parameters, but after a few days, it still shows in the pages report.
The parameter I added is chatid, and the urls are like domain.com/app/#/messaging?chatId=someID
Did I miss something ?

Hi! The params exclusion feature is case sensitive. Please change chatid to chatId.

Hi kuba,
Thanks for the answer.
The documentation states the opposite : “Added parameters are case-insensitive. For example, if you add _hstc , we’ll exclude _Hstc , _HSTC and _HstC.”
But at first, I added chatId, and it didn’t work either.

Sorry for confusion. It’s case sensitive starting from version 16.0. You’re most likely on 15.6 right now. I’ve reported a bug and the feedback I received is that it can be reproduced and it affects the first param after the ? sign. Next params should be properly excluded. We’re currently planning the updates to the higher version and that should be the solution in this case. Unfortunately, I don’t have the exact timing yet.

Ok, thanks. It is indeed the first parameter after the ? sign.