Consent form is showing up even though it has been disabled

Hi. I turned the consent form off, but it still appears on my website - along with my cookiebot. How do I remove your consent form from showing?

Hi. :slight_smile: How did you disable the consent form? Can you show a screenshot?

Is the website available publicly? Can you share the address here or on priv? I checked the URL from the screen and the form does not appear.

I removed the tracking code, because of the extra consent form. Is the tracking code active now again (justed turned on)?

I see that the code is installed and consent popup doesn’t appear. Maybe it was some cache on your end? Please also check in the incognito mode.

Yes, I think it works now. Thank you!

Hi again
Like you just saw yesterday I have installed the code. But how come I have no visitors (or anything) on my reports?


Hi. It’s because you’re using also Matomo on your site and it causes errors in browser’s console. See this article: Can I use Piwik PRO and Matomo at the same time? | Piwik PRO help center

Ok, thanks. I have changed the Matomo code, so it now sends to Piwik also. Should I remove Piwik code from the website?

You forgot about quotes in ilne 405 (browser’s console shows an error):

    _paq.push(['addTracker',, 4ea8f3a2-3d85-4e81-9fc3-623cab5b5759]);

So, currently the whole Matomo tracking might not work. If you are to add Piwik PRO in such a way, you’ll have to disable the Piwik PRO tag within the Tag Manager module.

I think it works. I used your guide, where there is no quotes:

I will remove the Piwik Pro code.

Mentioned code uses variables that contain that data. If you want to put it there directly, you have to use single quotes.

_paq.push(['addTracker', '', '4ea8f3a2-3d85-4e81-9fc3-623cab5b5759']);