Google Search Console "Redirect URI field have errors"

I’m trying to follow the many many steps to integrate Piwik with Google Search Console.

When uploading the json file I get the wonderful error message that my redirect URI fields have errors. What errors are these?

It seems that your setup is correct. I was able to reproduce the issue. Looks like a bug - passed to the engineering team.

@bwill I had the same error when using API credentials created few years ago (i only edited them). Perhaps it is also your case?
When I created everything from scratch, the new project, new OAuth consent screen and OAuth credentials then the integration was completed successfully.

I love making bugs.

I’ll try again either today or tomorrow and will report back.

I am having the exact same issue. How can this be fixed? Any solutions?
Schermafbeelding 2022-10-21 om 09.36.21

What is a creation date of the credentials that you’re trying to upload?

16 oct. So I waited for a week to check again. But same message.

I just went through the process on 2 different accounts and everything worked without an issue. Please make sure that you followed the instruction on the help center carefully as it might be an issue with the configuration.
It will be investigated by developers but likely in 2-3 weeks.