Google Search Console integration issue

I am trying to intergrate Google Search Console. I followed all the necessary steps:

and downloaded the JSON file from Google.

I come to this point:
“You haven’t selected any property or property doesn’t exist anymore. Please connect to other property to continue gathering data”.

After clicking “Select property” I get this error message:
“An error occurred during communication with server. Please try again later”.

How to proceed?

Thanks :slight_smile:

Could you attach a screenshot of the issue to see the exact step when it’s happening? Maybe it was some temporary issue on our end.

Sure

Our dev team is investigating the issue.

Thanks kuba, any update about this issue?

I have tried again, starting from zero, but now I can’t even upload the json file anymore, I get this error message:

Redirect URI fields have errors, change them in OAuth Client config and re-download file with new credentials details

I am sure I have copied/pasted the correct Redirect URL:

Thank you for your help!
Alwin

I am not sure if this will help at this current step of the integration process and with your specific problem already, but be sure to have published youe GSC publication status to. “in production”. Mine was set to “testing” at the beginning and I kept losing the API connection (which I could set up though succesfully initially). Setting it to “in production” fixed things for me.

Again, this might be for later concern for you. Definitely do whatever kuba recommends to you first.

Thank you for your help Sebastian, but the status is “In production”.

I also had that “Redirect URI fields have errors” issue. I described here the solution: Google Search Console "Redirect URI field have errors" - #3 by Jarek
Please let me know if that works for you.

It seems that something changed on Google’s side and might break the integration setup.

Hello Jarek,

I already did that yesterday, started from zero. Creation data is 20 October 2020.

I just have to wait for a response from kuba (and the dev team) I ques :slight_smile:

I tried it again today and now it works!

I don’t know what I have done different… :slight_smile:

Alwin

Thanks for letting us know. Still, we will have to check what is the root cause.