Conversion tracking not working

We recently integrated PiWik’s cookies acceptance with the consent form for the other cookies on our website. Since then, for some reason our goal tracking has stopped working.

My Developer has been doing some digging into the Piwik configuration and I believe the issue is actually on their side.

Our developer visited the page that should trigger the conversion (a registration confirmation page), yielding a conversion in the tracker debugger.

However, in the actual goal, nothing has shown as being converted, despite the tracking debugger displaying otherwise.

Any ideas on why this might be happening? It was all working before the integration, the error is occurring even on tests where we know for certain that cookies have been accepted, and the debugger seems to think it should work…

You might have to provide more details in order to receive a good hint

I just launched your page and had no consent window - is this intended?
You might don’t want to share those tokens in the picture publicly :slight_smile: ?

I cannot see how you have implemented the consent layer of piwik, thats might the root of the issue, as it might change the visit page url you are trying to fetch.

Have you tried to use another trigger which isn’t related to the url, like a click or scroll event?

The consent box should be at the bottom of the page when you go to I’ve just tried it on a private browser and it appears so should be working. See screenshot below. Our developer used the instructions on this page to integrate: How can I integrate a third-party cookie consent tool with Piwik PRO? | Piwik PRO help center

It’s collecting some data. Presumably if it wasn’t collecting any consent then we’d have no data at all? There’s not really a way to measure the goal in question without using the page url parameter. I do have another goal for page urls containing “crm”. I use this to help exclude our own staff from the stats. This is still working and collecting data…

You are right, I propably blocked this cookie banner unintended. I see it too.

@RiVentiv how are you checking if there are conversions on the reports? Generally, being able to see the conversion either in the session log or tracker debugger means that it works. If not, please let me know the actual goal you’re referring to and specific date and I’ll check that.

Thanks for replying - not sure I fully understand your question, sorry I’m not a developer so may not have all the knowledge I need here. I’m checking if there are conversions on the reports using the goal conversion column and selecting the relevant goal from the dropdown menu. There are three goals that aren’t working - the specific one here is called ‘Registration’ and should be triggered when someone visits a page containing ‘registration/done’ in th eurl. There should be dozens over the past month showing but there are none. They were showing before we integrated the cookie consent with our own so I’m assuming it’s something to do with that. The test that our developer conducted was on their developer site, rather than the live website, but he says it replicated the same issue (i.e. the report didn’t show the conversion). The conversions still show on Google Analytics, so users must be accepting cookies.

Hi. Just checked your website (sorry for filling in the form twice). The problem is connected with how the thank you page is handled. I see an instant redirect to:


Most likely it’s done without a full page reload, meaning that no page view event is registered. No page view on the thank you page = no conversions. It has nothing to do with the consent popup. Most likely it’s because the redirect is done via JavaScript. That’s fine, but in this case the page view has to be triggered somehow. I recommend setting up a virtual page view on this page. See docs: Virtual page view tag | Piwik PRO help center

The trigger for such a tag depends on the actual implementation (not sure if it’s a redirect or browser history api operation). You should end up seeing the following page URL in the tracker debugger without refreshing the page manually:


Hm this doesn’t sound right to me. If it redirects to a page with ‘event-registration/done’ in the url then that page would trigger the conversion, because the conversion is tracking any visits to a page with that exact string. The conversions were still working and tracking up to a few weeks ago when we made the change as well. If it was something to do with the confirmation page then I would assume it would have never worked…

Maybe with the introduction of consent manager the implementation of the thank you page changed somehow? I’m just sharing what I can see implemented on your website. It can be easily fixed by making sure that the page view is recorded once again.

It’s not just that it doesn’t pick up the conversion, it doesn’t record that a page with that url has been viewed at all. If I search the Pages report for confirmation pages, it shows no page views at all, but the equivalent report on Google Analytics will show a very high number…

But that was my point. The issue is lack of the page view on the thank you page. If that worked, the conversion would be collected. So the only thing that needs to be fixed is making sure that the page view works there.

OK - so that gets us onto the question of why the age view might not be working. Is there anything on that page we should be checking?

All other pages reload fully after going to different parts of the website. The thank you page reloads without a full page refresh after filling in the form, meaning that most likely the standard page view trigger in the tag manager doesn’t work.

How to fix that?

  • change the form to cause a full reload
  • add a virtual page view tag on the thank you page to manually trigger the page view

So we tried this but still no luck. Is there anything else we can try?


Just to add to this we’ve done a bunch of tests this morning and the tracker debugger shows the whole session but then not the registration confirmation page. We’ve created the virtual view tag, as suggested, but still no luck. We have a developer site as well and it all seems to work on there so we’re completely stumped as to why it wouldn’t work on the live site.

This is what shows on the debugger, but the confirmation page definitely loaded and, as I said, it works on the developer site…