Analytics is showing zero visitors after few weeks

Dear support,

About one week ago I installed Piwik PRO script on my landing page ( using this article Set up your account | Piwik PRO help center.

Unfortunately, the UI doesn’t show any statistics.

I’m not sure what to look into. Could you please help me with resolving that?

Thank you in advance.

What is your current consent setting for Piwik Pro Analytics in your Piwik Pro Tag Manager, It’s usually set to analytics by default

If you aren’t using the Piwik Pro consent manager, you can also navigate to Privacy settings in the Administration menu and turn off do not ask visitors.

Let me know if this worked, thanks

Hi @jude_nwachukwu , thank you for your reply.

These are the consent preferences right now. I haven’t changed them for more than a week. Could they cause the problem?

Go to your Tag Manager, by clicking on the menu, select the Piwik Pro tag and scroll down to consent type and change it to not use consent

After this update, click on publish by the right and wait for data to start collecting

Hi :slight_smile: Consent type is ignored when consent manager is disabled.

I just checked your site and the container is properly installed. I can see events triggered by the browser. Have you checked the tracker debugger if the events appear there?

Hi @kuba, yes, I can see the events in the tracker debugger

Btw, now I’m getting a new error in my browser console

I’m not sure where it is coming from.

It looks correct now. Check the reports in 30 mins from now.

The disablecookie notification does not break tracking. Most likely you disabled cookies in two places (website settings and Piwik PRO tag in Tag Manager).

@kuba , @jude_nwachukwu . Folks, it’s been more than 4 hours, but I’m still getting zeros into my analytics.

Could it be some kind of bug in the PiwikPRO implementation?

Are you checking the right Website? What is the date range you have selected? Could you check if data is available in the standard Reports section? A full screenshot would help a lot.

@kuba, you’re right sir. I’m one of these people who forget to turn the computer on and blame the IT guy :man_facepalming: I’ve just set the correct date range and it’s working as expected. Thank you for your help.

1 Like