The Only essential cookies button (reject all) is only triggering on the text

Hi, please check this site in private browser so the cookie warning pop-up comes up:

Hover over the buttons to see when they trigger. You will notice that the Accept All will trigger in the whole button area (the orange box) while the Only essential will only trigger on the text (actually first row of text) and not in the whole white box.

The result is that people clicking beside the text thinks that the button is not working.

Hi @Terve,

It’s due to the fact that the button is overlayed by the other element

So you should either edit the element in the consent editor so that it no longer overlaps or do so by custom code for example by changing the z-index of the “accept only…” button


Thanks Oliwer, I see it now. I am not a developer but I think that it is weird that you can only size the Division by setting margins and padding and not the size. This will appear very differently on mobile and desktop. It is hard to get it to look good on mobile, see attached screenshot, the small white buttons is not looking great and nor does the save and close button.

I fixed the original issue by increasing the margin between the text and the small white buttons (on DIV level). I also made a large margin for the Accept only essential button, so that the analytics switch was not hidden when opening consent settings.

I created a Feature Request to make the editing better. For now if you would want it to look like previously but without the issue you’d have to use custom code and CSS.

Thanks, Oliver; I have got it ok now, but not great.