Websocket connection error


I am having troubles viewing any reports in a Piwik Pro Core Account. When selecting any standard report like the Pages-report or Channels or anything else just gives a “In queue”-message on the screen and nothing else happens.

After a while I am sent to an error page: “Websocket connection error” with this text: “Application could not connect to the websocket service. It could be blocked by ad blocking plugin (e.g. AdBlock or uBlock) so check if you’re using it, disable it on this site and reload the page. If it won’t help, please contact your network administrator and ask if websockets are blocked on this site by your organization.”

The problem is pretty consistent over quite a few weeks, although I have been able to use the tool a few weeks ago. I have made no changes in the tracking code or other setup-related things, which could explain any problems.

I have tested in Chrome and Edge. There are no adblockers in either.


Have you tried using different network? Maybe you have some internal filters that you’re not aware of.

It worked using a mobile hotspot instead of the WiFi. Thanks!

Do you know which network issues usually cause this problem? I haven’t experienced it on anything else. And it seems silly to have to use a mobile hotspot only for Piwik

Is it some corporate WIFI or a private one?

It’s my home Wifi (fiber)

So either some filtering set up on your router or something done by the ISP.

I had the same problem for a couple of weeks and then it disappeared without my intervention despite of a few things like deleting all cookies and stuff that I tried as a solution for the problem before (without any effect).

I used Firefox as a fix for a while where the problem did not occur while Chrome refused to load any data. For whatever reason… so the connection can not be the (only) explaination.